Press "Enter" to skip to content

Posts tagged as “jdk”

杂谈篇之我是怎么读源码的,授之以渔–code

大虾 0

  开心一刻    今天上课不小心睡着了,结果被老师叫起来回答问题,这是背景。无奈之下看向同桌寻求帮助,同桌小声说到选C,结果周围的人都说选C,向同桌投去一个感激的眼神后大声说道选C。刚说完教室就笑开了,老师一脸恨铁不成钢的表情说选你个头,我叫你翻译文言文你选C!你出去,你给我出去。看着同桌挤眉弄眼的表情,劳资真想说,这帮畜生

编程语言Java的JDK–code

大虾 0

JDK是java语言的软件开发包,主要用于移动设备,嵌入式设备上的java应用程序。JDK是整个java开发的核心,它包含了java的运行环境(JVM+API(java系统类库))和java工具。
Path环境变量的作用是设置供操作系统去寻找可执行文件的路径的顺序;
ClassPath环境变量的作用是JVM执行java程序时搜索类的路径的顺序。

我是如何将博客转成PDF的–code

大虾 0

只有光头才能变强之前有读者问过我:“3y你的博客有没有电子版的呀?我想要份电子版的”。我说:“没有啊,我没有弄过电子版的,我这边有个文章导航页面,你可以去文章导航去找来看呀”..然后就没有然后了。

tomcat学习步骤,附带打破双亲委派模型企业应用实战–code

大虾 0

入门模块仅做学习大纲梳理,忽略了具体操作指引。                                                                                                                                               通道(Channel)、缓冲区(Buffer)、选择器(Selector)

java基础之多线程–code

大虾 0

目录  进程:进程指正在运行的程序。确切的来说,当一个程序进入内存运行,即变成一个进程,进程是处于运行过程中的程序,并且每个进程都具有一定独立功能。
  线程:线程是进程中的一个执行单元,来完成进程中的某个功能。负责当前进程中程序的执行,一个进程中至少有一个线程。一个进程中是可以有多个线程的,这个应用程序也可以称之为多线程程序。
  简而言之:一个程序运行后至少有一个进程,一个进程中可以包含多个线程。

做Servlet之前eclipse如何配置?–code

大虾 0

1.先期的eclipse的配置  (视频下载) (全部书籍)1) 配置eclipse的jdk的方法:window/preferences(偏好) /java/Compiler/Compiler compliance level:我设置的是1.6(你最好跟我一样,【新手可互略这段的解释】1)这里设置的是eclipse中所有项目的,想设置某个单独项目的 compiler,可设置它的project facet中的java compiler。2)这个1.6指的是你的servlet编译成的class版本是1.6,而不是jsp编译成servelet class的版本,那个版本是什么,学jsp时再告诉大家。)。(编译和tomcat运行jre版本要一样,否则有版本major.minor错误, tomcat不是exe,它运行时,需要你的系统装有java,这里你的eclipse的tomcat运行,所需要的jdk在哪呢?window/preferences/Server/Runtime Enviornment/tomcat5.0/Edit/Jre/Installed Jres,多说一句,外置生产环境下的tomcat的jre呢?在外置tomcat安装目录的bin目录下敲:version)
2)配置eclipse的jre的方法:window/preferences(偏好)/java/Installed JREs:我勾选的是1.6.注意:这里eclipse有问题,一定注意不是jre虽然它写的是jre,其实这里一定要指向jdk1.6的路径(【新手可互略这段的解释】网上有种说法是eclipse自带jdk,所以这里只需设置jre,我们不深入研究这种说法),因为jsp运行时需要编译成servlet,如果你只给出jre的路径,到时候无法编译jsp。(这样整个的项目facet都是1.6,这样项目全面都是1.6版本的,单独设置jdk为1.6不行,不能运行)3) 配置tomcat的方法:(首先声明我用的是一版不用安装的Tomcat【到处随便拷贝】,你可以安装一个Tomcat,对于之后的操作是一样的) window/preferences/server/Runtime Environment/Add/Apache/Apache Tomcat5.0:在之后的tomcat installation directory当中,输入你的tomcat的根目录。而且jre版本一定和你的eclipse的compiler版本一致,对于我来讲,就是 jdk1.6。